Wireshark-bugs: [Wireshark-bugs] [Bug 6303] Incorrect dissection of ZigBee "Configure Reporting
Date: Fri, 2 Sep 2011 09:58:16 -0700 (PDT)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=6303

Bill Meier <[email protected]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|Major                       |Minor

--- Comment #1 from Bill Meier <[email protected]> 2011-09-02 12:58:15 EDT ---
This is essentially the same issue as reported in Bug #6304.

I note from the spec (page 31):

"2.4.8.1.3 Status Field
The status field specifies the status of the configure reporting operation
attempted on this attribute, as detailed in 2.4.7.3.
Note that attribute status records are not included for successfully configured
attributes, in order to save bandwidth. In the case of successful configuration
of all attributes, only a single attribute status record shall be included in
the command, with the status field set to SUCCESS and the direction and
attribute identifier fields omitted."


Again, similarly to the note in Bug #6304:

The way I read the above, it would seem that in the SUCCESS case there should
be no direction or attribute ID (and thus the packet is arguably actually
malformed).

I'll defer to someone familar with the protocol....

-- 
Configure bugmail: https://bugs.wireshark.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.