Wireshark-bugs: [Wireshark-bugs] [Bug 6020] New: pinfo.cols.protocol not holding value
Date: Tue, 14 Jun 2011 15:24:21 -0700 (PDT)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=6020

           Summary: pinfo.cols.protocol not holding value
           Product: Wireshark
           Version: 1.6.0
          Platform: x86-64
        OS/Version: Windows 7
            Status: NEW
          Severity: Normal
          Priority: Low
         Component: Wireshark
        AssignedTo: [email protected]
        ReportedBy: [email protected]


Build Information:
Version 1.6.0 (SVN Rev 37592 from /trunk-1.6)

Copyright 1998-2011 Gerald Combs <[email protected]> and contributors.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Compiled (64-bit) with GTK+ 2.22.1, with GLib 2.26.1, with WinPcap (version
unknown), with libz 1.2.5, without POSIX capabilities, without libpcre, without
SMI, with c-ares 1.7.1, with Lua 5.1, without Python, with GnuTLS 2.10.3, with
Gcrypt 1.4.6, without Kerberos, with GeoIP, with PortAudio V19-devel (built Jun 
7 2011), with AirPcap.

Running on 64-bit Windows Server 2008 R2, build 7600, with WinPcap version
4.1.2
(packet.dll version 4.1.0.2001), based on libpcap version 1.0 branch 1_0_rel0b
(20091008), GnuTLS 2.10.3, Gcrypt 1.4.6, without AirPcap.

Built using Microsoft Visual C++ 9.0 build 21022

Wireshark is Open Source Software released under the GNU General Public
License.

Check the man page and http://www.wireshark.org for more information.
--
Within a Lua based post dissector, setting the pinfo.cols.protocol seems to
work intermittently.  Sometimes it prints my protocol name (G2S), much of the
rest of the time it reverts to HTTP/XML.  When I enter G2S as a filter, I get
all of the proper packets displayed, and my post dissector display the data
from xml.cdata that it should, but the Protocol column shows G2s on the first
packet, then 3 HTTP/XML, one G2S, 12 HTTP/XML, one G2S, 4 HTTP/XML, 3 G2S, 14
HTTP/XML, 1 G2S, etc., etc.

In V1.4 this same script would display G2S for all packets that are correctly
G2S.  In the Forums, I posted a question titled Lua Post Dissector from V1.4
breaks in V1.6 describing the bug and if anyone else could replicate.  One
respondent said he could, and therefore please file as a bug. See that posting
for additional details.

-- 
Configure bugmail: https://bugs.wireshark.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.