Wireshark-bugs: [Wireshark-bugs] [Bug 5593] Malformed Packet: ULP reported when dissecting ULP S
Date: Sat, 22 Jan 2011 09:45:59 -0800 (PST)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5593

--- Comment #3 from e.yimjia <[email protected]> 2011-01-22 09:45:57 PST ---
(In reply to comment #2)
> (In reply to comment #1)
> > Updated asn1 Committed revision 35577.
> > The bug is still there though. You could try older WS versions 1.4.0?
> > It may have gone broken by updates to packet-per.c I tried another ULP
> > trace I got and it had the same error so I doubt it's your encoding.
> > Regards
> > Anders
> 
> Hi, I've tried following version( winXP and portable version ):
> 
> 1.2.5  -> could dissect the msisdn part, ULPv2 cannot be decoded
> 
> 1.3.0  -> could dissect the msisdn part, ULPv2 cannot be decoded
> 
> 1.3.5  -> could dissect the msisdn part, and could decode the first PDU ( which
> is ULPv2-only TRIGGEREDSTART ) message successfully
> 
> 1.4.0  -> failed, same as the bug description
> 
> 1.4.3  -> failed
> 
> something in 1.4.0 broken the ULPv2 dissect function.

Hi,
I've tried 1.2.14 with packet-per.c version 34531 and it's OK to decode the ULP
PDU, but when I tried 1.4.3 with packet-per.c version 34531, still got the same
problem, so it looks updates to other files caused this problem rather than
packet-per.c .

best regards.

-- 
Configure bugmail: https://bugs.wireshark.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.