Wireshark-bugs: [Wireshark-bugs] [Bug 4191] Wireshark Portable installer outdated
Date: Thu, 9 Dec 2010 07:18:22 -0800 (PST)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=4191

--- Comment #7 from John T. Haller <[email protected]> 2010-12-09 07:18:19 PST ---
(In reply to comment #6)

> John, any update?
> 
> BTW, I see the installer is now at 2.0.6.  I'm curious as to how many updates
> there have been since you went to 1.0, and what impact, if any, each one has?

The installer is now self-contained and, while it will generate NSIS code you
could drop into your build system, it will only work with NSIS Unicode with a
specific set of plugins.  As such, it's best to use the PA.c Installer to
compile your PAF.exe directly.  This works on a Windows box or a *nix/*bsd box
with a current version of Wine installed.

The only other things needing changes would be the files in AppInfo as we've
updated the format.  The installer entirely generates the appropriate NSIS code
and compiles it using a built-in pre-configured copy of NSIS Unicode based on
that.  Would it be best to do this as a proposed patch right in this bug
report?

Once that's done, we can get Wireshark listed on PortableApps.com and exposed
to our millions of users.

-- 
Configure bugmail: https://bugs.wireshark.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.