Wireshark-bugs: [Wireshark-bugs] [Bug 2145] Lua dll is outdated in windows binaries
Date: Tue, 30 Sep 2008 06:46:47 -0700 (PDT)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=2145





--- Comment #3 from Balint Reczey <[email protected]>  2008-09-30 06:46:45 PDT ---
There were several Lua updates since 5.1.1: http://www.lua.org/bugs.html#5.1.4
Could it be updated in the windows bundles?


(In reply to comment #2)
> Hi,
> Yes, there is no big difference mentioned in the history.txt, but it seems,
> that there were more minor changes  if we compare the source for the two
> versions. :-(
> I submitted that bug report, because we experienced some strange errors while
> running the Windows version that we could not reproduce on Linux.
> On Linux, i used Lua 5.1.2 (packaged for Debian Lenny), but on Windows, i found
> that the bundled Lua version was only 5.1.
> I'm not sure that the version problems were related to Lua version 5.1 and
> unfortunately i cannot test whether the problems appear on Lua 5.1.2 because i
> don't have access to the Windows machine currently.
> 
> (In reply to comment #1)
> > Hi,
> > From what I can see there is no big difference between 5.1 and 5.1.2
> > http://luabinaries.luaforge.net/#history
> > History
> > [09/Apr/2007] 
> > Lua 5.1.2 - Release 1
> > Added a dll proxy called "lua51.dll" in the dll packages. It can be used to
> > replace other "lua51.dll" previously released. It will simply forward calls to
> > the "lua5.1.dll". There is no compiled source code involved in the forwarding. 
> > [14/Mar/2007] 
> > Lua 5.1.1 - "luac5.1.exe" updated in the current zip to fix a problem with the
> > "-l" parameter. 
> > [10/Nov/2006] 
> > Lua 5.1.1 - Release 1 
> > 
> 


-- 
Configure bugmail: https://bugs.wireshark.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.