Wireshark-bugs: [Wireshark-bugs] [Bug 1677] wireshark-0.99.6 does not compiles with --as-needed
Date: Tue, 16 Sep 2008 12:27:08 -0700 (PDT)

--- Comment #20 from Jeff Morriss <jeff.morriss.ws@xxxxxxxxx>  2008-09-16 12:27:07 PDT ---
(In reply to comment #18)
> Well, but some further fixes are still required... Reopening as wireshark-1.1.0
> build fails with the following error:

When I added libwsutil I neglected to link either wiretap or libwireshark
against it and instead linked all the executables against it (which goes
against the principle of what --as-needed is trying to do).  <sigh>  I fixed
that in rev 26218.

The problem in comment #19 means libwireshark (still) depends on libwiretap for
the PPI dissector.  I don't know what to do about that (I still don't like the
idea of libwireshark depending on libwiretap).

Configure bugmail: https://bugs.wireshark.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.