Wireshark-bugs: [Wireshark-bugs] [Bug 1216] New: Wireshark Crashes when trying to start a captur
Date: Fri, 10 Nov 2006 18:15:02 +0000 (GMT)

           Summary: Wireshark Crashes when trying to start a capture
           Product: Wireshark
           Version: 0.99.4
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: Major
          Priority: Medium
         Component: Wireshark
        AssignedTo: [email protected]
        ReportedBy: [email protected]

Build Information:
Version 0.99.4 (SVN Rev 19757)

Copyright 1998-2006 Gerald Combs <[email protected]> and contributors.
This is free software; see the source for copying conditions. There is NO

Compiled with GTK+ 2.6.9, with GLib 2.6.6, with WinPcap (version unknown), with
libz 1.2.3, with libpcre 6.4, with Net-SNMP 5.3.1, with ADNS, with Lua 5.1,
GnuTLS 1.5.1, with Gcrypt 1.2.3, with MIT Kerberos, with PortAudio <= V18, with

Running on Windows XP Service Pack 2, build 2600, with WinPcap version 4.0 beta
1 (packet.dll version, based on libpcap version 0.9.4 branch,

Built using Microsoft Visual C++ 6.0 build 8804

Wireshark is Open Source Software released under the GNU General Public

Check the man page and http://www.wireshark.org for more information.
When starting a capture Wireshark crashes with a "Wireshark has encountered a
problem and needs to close".
Additional information states 
AppName: Wireshark.exe AppVer: ModName: icm32.dll
ModVer 5.1.2600.2709  Offset: 000433c.

This is not a problem with WinPcap or the drivers - windump works just fine.
The problem also occurs with Ethereal version 0.99.0 as well as WinPcap version
icm32.dll was updated by the windows fixpack WindowsXP-KB901214-x86-ENU.
Wireshark crashes in a different place (same module) if this fix pack is
removed. I have the this same problem with my laptop but it appears to work
with my home machine. If I load Ethereal 0.10.10 on the laptop (same winpcap)
it works.
When using Ethereal 0.99.0 I downloaded an older version (1995) of icm32.dll
and placed it in the Ethereal directory, then I could start an ethereal capture
but when I put in a filter and started the capture the machine rebooted. 

All machines running Windows XP Professional Version 2002 Service pack 2 and
are current as to MS patches. Main machine has a gig card. Laptop has a gig
card and  a xircom 100 meg card (neither work under 0.99.4)
Any help is appreciated - Thanks.

Configure bugmail: http://bugs.wireshark.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.