Ethereal-dev: [Ethereal-dev] CVS Win32 GTK2 version of ethereal immediately crashes

Note: This archive is from the project's previous web site, ethereal.com. This list is no longer active.

From: "Olivier Biot" <[email protected]>
Date: Tue, 13 Jul 2004 09:10:27 +0200
Hi list,

Yesterday I attempted at recompiling Ethereal after a while (1 week or
so), and did a nmake distclean followed with a cvs update, nmake setup
and nmake packaging). The make process downloaded new libraries (maybe
there are duplicates in my build environment?). Compilation went on
flawlessly, but when I unpack Ethereal and run it, I invariably get
the following issue followed with a real crash (not an exit):

(ethereal.exe:2820): Gtk-WARNING **: Unable to locate theme engine in
module_path: "wimp",

(ethereal.exe:2820): GdkPixbuf-WARNING **:
Error loading XPM image loader: Unable to load
image-loading module:
C:\Program Files\Ethereal/lib/gtk-2.0/2.2.0/loaders/
libpixbufloader-xpm.dll: Kan opgegeven module niet vinden.
<<Meaning: can't find the specified module>>

(ethereal.exe:2820): Gdk-CRITICAL **:
file gdkpixbuf-render.c: line 297
(gdk_pixbuf_render_pixmap_and_mask_for_colormap):
assertion `GDK_IS_PIXBUF (pixbuf)' failed

Ethereal crashes on WinXP and I get the famous dialog asing whether I
want to send the report to Microsoft.

If I uninstall Ethereal hereafter and reinstall it *without* Gtk-Wimp,
then I get the same crash, however the 1st warning does not pop up.

Anyoe a clue?

Best regards,

Olivier