Ethereal-dev: [Ethereal-dev] Win32: Changes to the NSIS installer?

Note: This archive is from the project's previous web site, ethereal.com. This list is no longer active.

From: Ulf Lamping <[email protected]>
Date: Sun, 11 Jul 2004 12:27:55 +0200
Hi!

If I remember it correct, the NSIS installer needs to detect, which windows version it runs on, as GTK-Wimp will not work pleasantly on all windows systems.
So the GTK-Wimp should *not* be installed:

-when installing GTK version 1.x
-when install on Win9x/ME/NT 4.0

-> GTK-Wimp should only be installed for GTK2.x on 2000/XP/2003 systems.

I would like to change the current installer, that it will detect the os version, and will select installing GTK-Wimp according to the above conditions. I won't do a read-only selection of the Gtk-Wimp, so the user could take a different decision if he/she likes.

Are there other things where the NSIS installer lacks functionality?

Regards, ULFL