Ethereal-dev: Re: [Ethereal-dev] mergecap fails to link on Solaris 9 (needs getprotobyname() e

Note: This archive is from the project's previous web site, ethereal.com. This list is no longer active.

From: Jeff Morriss <[email protected]>
Date: Thu, 08 Jul 2004 16:42:34 -0400

Guy Harris wrote:
Jeff Morriss said:

I updated my CVS tree to release-0-10-5 and tried to compile on Solaris
9 but 'mergecap' fails to link:

I don't see "mergecap" anywhere in the "make" output - it looks as if it's
trying to link Ethereal.
Hmmm, that's odd.  I swore I saw "mergecap" in there earlier today.  <sigh>

The configure script appears not to have determined that libpcap requires
-lsocket, although it did figure out that it needs -lnsl.

Could you send the config.log file from the top-level source directory?
In fact I discovered (when I tried it on Solaris 8) what I previously 
knew (and forgot):  GTK2 is now the default.  Using "--disable-gtk2" 
makes everything work--don't know why (note that I installed GTK1.2 but 
the GTK2 is from Solaris).
Anyway, here's the "config.log" from when it didn't work.

Attachment: config.log.gz
Description: GNU Zip compressed data