Ethereal-dev: Re: [Ethereal-dev] Webbrowser call: doesn't work with GLib1.x

Note: This archive is from the project's previous web site, ethereal.com. This list is no longer active.

From: Ulf Lamping <[email protected]>
Date: Wed, 07 Jul 2004 18:34:58 +0200
Guy Harris wrote:

On Wed, Jul 07, 2004 at 09:39:59AM +0200, Ulf Lamping wrote:
When looking at the recent changes made, I was aware that the current implementation of webbrowser.c lacks support for Glib1.x versions.
So if Glib 1.x is used (not on MAC OS X or Win32 platforms), you have 
the menu items to select the webbrowser pages, but when clicking on it,
simply nothing happens.

As I don't have a short hand solution to do it right (call the browser somehow), do we want to disable the corresponding menu items in that case (temporarily for this release)?
That sounds reasonable.  (Unless somebody takes the effort to make GLib
1.2[.x] and GTK+ 1.2[.x] to build as dynamically-linked libraries,
people aren't going to be able to build for OS X with GLib 1.2[.x]; I
don't think we support GLib 1.3[.x] on Win32, either, so this might just
be doable as "if GLib 1.x, don't offer those menu items".)

Checked in a fix.

Regards, ULFL